PHP: Hypertext Preprocessor, otherwise called PHP, is a famous coding language, which can be used to set up dynamic websites with interactive elements like discussion forums, e-teaching sites or social networks. In comparison with static HTML-based websites, a PHP website can serve different web content to each visitor under the same exact page URL. Considering the fact that PHP-based web-based applications can be managed through one single Control Panel, which you can log in to from any web browser, you won’t need any web development experience or past experience in order to administer a PHP-driven site. The fact that 100s of millions of websites all over the world are created in PHP is indicative of the popularity and the ease of use of the language. You must only verify if the server on which your site is hosted supports the same exact version of PHP as the one that you used whilst building the site.

PHP 4 and PHP 5 Support in Cloud Web Hosting

With our Linux cloud web hosting, you’ll be able to select the PHP version that will be enabled for your web hosting account, as several versions are supported on our servers. With only one click of the mouse, you will be able to switch between PHP 5.5, 5.4, 5.3, 5.2 and 4 and each time a new version is published in the future, we will add it to the Hepsia Control Panel without removing the previous versions. Thus, you will be able to host all the websites that you’ve built over the years. In contrast to lots of other hosting suppliers, we won’t compel you to update such websites, because a script may be out of date, but this does not automatically mean that it is insecure since you may have modified its source code to plug security gaps. For the sake of your convenience, you’ll even be able to specify a different PHP version for each single site hosted in your web hosting account.

PHP 4 and PHP 5 Support in Semi-dedicated Hosting

In case you’ve got a website built using a previous PHP version and you’ve donated time and energy towards setting it up, repairing security breaches and appending web page content, you’ll need to find a hosting service that can support it, as nearly all web hosts these days support only the latest PHP version and drop the previous versions. We, however, have decided to allow you to select the exact version that your sites need. Our Linux semi-dedicated hosting support PHP 4 and multiple versions of PHP 5, which suggests that you will be able to use both older and newer scripts without losing any manual settings or misspending time and energy trying to make your websites compatible with the web hosting platform. You can change the current version from the Hepsia hosting Control Panel and such an update will affect the entire account, but you will also have the ability to select a different PHP version for each individual website that you host in your account using an .htaccess configuration file.